Getting Started Using M entor Graphic’'s ModelSim

There are two modes in which to compile designs in Model Sim, classic/traditional mode and
project mode. This guide will give you a short tutorial in using classic/traditional mode. Itis
broken down into the following sections

Part 1: Compiling a Design

Part 2: Simulating a Design
Transitioning to the Next Lab

Setting Simulator Resolution

Directory Structures and Running Scripts
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1 Part 1: CompilingaDesign

1.1 CodeYour Design
Code your design per the lab directions.

1.2 Start ModelSim

Start Model Sim by double clicking on the Model Sim Icon (windows) or by typing "vsim &" in
the shell (UNIX). If you window does not look as below, select the menu command "Layout >
Reset". Note the workspace, transcript and source windows can be moved.

¥ ModelSim SE 10.0

File Edit Yiew Compile Simulate pt Tools Lavout Window Help rem— M
B = & B 3 S
B LECET IETE <4+-—— Buttons
1 Ubrary i Hdf x| Objects w H A x| \ _—
"1Name ‘Type |Path B Marne Tlvalue  |Kind  [Mode
l'—m mkifm Library $MODEL_TECH/. . favm
ll‘m Floatfixlib Library $MODEL_TECH]. . /Floatfixlib
ﬂ—m ieee Library $MODEL_TECH/. . fieee
m me2_lib 1 Library $MODEL_TECH/. .fmc2_lib Ot h er
ﬂ‘m modelsim_lib Grary $MODEL_TECH/. . /modelsim_lib > .
+ mkiCHm Libr $MODEL_TECH. Javm-2.1.1 ﬁ Processes (In Region) s Hdl = WI n d OWS
2l miea Library N $MODEL_TECH]...fpa_lib [*hiame [Type (fitered)  [State  |Order |Pare -
gl std Library  \$MODEL_TECH/. fstd
ll‘m std_developerskit Library MODEL_TECH/. . /std_develapersk
l'—m sv_std Library MODEL_TECH/. . fsv_std
ol VL Vikwarn FAANEL TECHE bevmnrsus j )
‘|
# // Modeliim 3E 10.0 Dec B 2010 o
# /7 T
# 7/ Copyright 1991-2010 MEntor Graphics Corporation
# // A&ll Rights Reserved.
# /7 Tz
# // THIS WORK CONTAINSG JRADE SECRET AND FROPRIETARY INFORMATION
# // WHICH I3 THE FROPER OF MENTOR GEAPHICS CORPORATION OR ITH ﬂ
<No Design Loaded > I ‘(Nn Context > g |
Copyright © 1999 - 2011 by SynthWorks Design Inc. All rightsreserved Rev 1110 ModelSim - 1



Using ModelSim

1.3 Set theWorking Directory

Use the Model Sim menu command "File > Change Directory" to set the working directory*.
For lab 1, browse to the directory "V hdlIntro/Chipper/vhdl_src" as shown in the following dialog

box.
Browse for Folder E‘B\

Please choose a directory, then select 0K,

CiistudentiwhdlIntrobChipperivhdl_src

vhdl_src

=) YhdlInkro -~
D) Answers
(=7 Chipper
() sim_aldec
) sim_rnki
(2 syn_synplicity

) DigitalClock, “

[ Ok, H Cancel ]

Noteif asimulation is active, you cannot run change directory. First you must end the
simulation with the Model Sim menu pull down "Simulate > End Simulation”.

14 CreateaWork library

A library isacontainer of compiled VHDL designs. You can think of alibrary asaformal
storage location for object files (similar to "C" language * .o files).

Before compiling your design, you must create the work library. Use the Model Sim menu
command "File> New > Library" to create the work library. The library pop-up window should
look like the following when you are done.

#Create a New Lib... E|

Create

" anew library
" amap to an existing library

* anew library and a logical mapping to it

Library Mame:

I;JCI]:]'{

Library Physical Mame:

|wor}:

(o4 Cancel
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Using ModelSim

1.5 CompileaDesign

In order to run asimulation, al files (design and testbench) that are to be used in the ssmulation
must be compiled. Use the Model Sim menu command "Compile > Compile" to compile a
design (Inc.vhd for the first part of lab 1) into the work library. This causes the following
pop-up window to appear. In the pop-up window select Inc.vhd and press the compile button.

Compile Source Files g|

Library: |w0rk j
Look in: | ) vhdl_=ic j I‘j‘ '
L.b Chwork (A switchelk vhd
R [Achipper whd [#)SwitchDebounce vhd
Documonts | Z1CIkPrescale vhd [ATEChipper vhd
[HADoubleReqg.vhd [ATELedCmd.vhd
[ ThLedCtrl.vhd
Desktop |2 e Th.vhd [ATELedFlasher vhd
[ALedcmd vhd [ATELedFlasher_lab6 vhd
[ALedctr! vhd [ATETimePulze vihd
My Dacurents |21 edFlasher vihd [ATETimer .vhd
. [#)pushButtonAddr vhd - [ TimePulse vhd
w8 HPushButtonCounter vhd [ Timer.vhd
e [HResetBlk.vhd
My Computer .
)
Mypf;lafimk File name: |Inc.vhd j Compile |
Files of type: |HDL Files [*. ;% vl vhd" vhdl” vho;".hdl;‘.vo;j Dane
[~ Compile selected files together Default Options | Edit Source |

After compiling your design successfully (check transcript window for error messages), close the

pop-up dialog box by pressing’

'Done".

The key to understanding error messages is to realize that the message is produced after the
compiler getslost. In the example below (note thisis not your lab design), the entity Adder8 has
a‘; after thelast port declaration. Most often this means that the error message will be
generated on line 43. Thisis common, so make sure when you get an error message to read the
specific error message and realize the root cause may be something done on the previous line
that causes the compiler to "detect” the error on the current line.

39 -- Not the lab design

39 entity Adder8 is
40 port (

41 A, B - In std _logic vector(7 downto 0);
42 Y > Out std_logic_vector(7 downto 0);
43

)
44 end AdderS8 ;

-- error

Also note that when you get an error message, you can double click on it and the ModelSim

editor will take you to the linei

n error.
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2 Part 2. Simulating a Design

2.1 Codethe Testbench
Code the testbench per lab directions.

2.2 Compilethe Testbench

Compile IncTh.vhd using the steps from “"Compile aDesign”.

2.3 Loadthe Testbench = Start the Simulation

Go to the library tab of the workspace, press the plus sign to expand the work library, and right
click on your testbench (inctb) and select simulate. Do not double click on your testbench as this
starts an optimized simulation. Do not load your design (Inc), instead, it is loaded as a result of

the testbench being loaded.

When the simulation loads, the simulation window will overlay the library window as shown
below. Y ou can switch back and forth between the two windows using the "ssm" and "library”
tabs. Close the Objects and Process windows by pressing on the " X" in the right corner.
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Using ModelSim

2.4 Display Waveforms

Display the waveforms after loading the testbench and before running the simulation. To display
waveforms, select the design under test (inc) in the "sim" tab, right-click the mouse, and select
"Add > To Wave >All itemsin region".
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Alternately, bring up awave window by selecting "View > Wave" in the Model Sim menu.
Select adesign (such asu_inc) inthe"sim" tab of the Model Sim workspace and click and drag
the design to the wave window.

2.5 Runthe Simulation

For lab 1, you will be running your design for 720 ns. To do this, change the default run length
(see picture above) to 720 ns (typeit in the box). Now select "Simulate > Run > Run 100*".
On some revisions, the 100 will be replaced by the actual run time.

Note that it is quite normal to see warning messages at the start of the smulation. Most
messages that occur before adesign isinitialized and/or reset can be ignored. For example, the
following warning results from the A input being initialized to "UUUUUUUU" at time O:

# ** Warning: There is an "U"|*X"|*W"]"Z"]"-" in an arithmetic

operand, the result will be "X"(es)!
# Time: 0 ns Iteration: 0 Instance: /inctb/u_inc

Note that if you forgot to display your waveforms before running the ssmulation or find a bug
during simulation, you will need to re-run the ssimulation. See the next section for details.

Copyright © 1999 - 2011 by SynthwWorks Design Inc. All rightsreserved Rev 1110 ModelSim -5



Using ModelSim

2.6 Recompiling and Rerunning a Simulation

VHDL designs are required to be compiled bottom-up. If you find and fix abug in your design,
you will need to re-compile both the design (Inc.vhd) and the testbench (IncTh.vhd).

To re-run asimulation, instead of starting a simulation, use the restart command. Restarting a
simulation sets the time to O, reloads any recompiled designs, and maintains the current context
(such as signalsin the wave window). Restart asimulation by using Model Sim menu item
"Simulate > Restart". Thiswill cause the following pop-up to appear. Press the Restart button.

7 Restart g|

Keep:

¥ List Format

¥ ‘Wave Format

¥ Breakpoints

¥ Logged Signals
I Yirtual Definitions
¥ Assertions

¥ Cover Directives

¥ ATY Format

0K Y Cancel

At this point you can set breakpoints, display additional signals, and run the smulation (using
the Run command described previoudly).
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2.7 Using the Waveform Window

All commands described in this section are done with the waveform window undocked. To
undock the wave window press on the undock button (see diagram in the Displaying
Waveforms section —it is the box with an arrow pointing out of it). The waveform window
menus should now look as below (you may need to stretch it some). Other changes made
to the wave window will be explained in this section. Note the same menu commands are
available when the wave window is docked, however, they are more difficult to find.

Wave
' Edit View Add Format Tools Window

@fE- 4«9 B[ 1elEARBEc WP UHE || RQARAAHR

b Msgs

43
& 52 = 28 [ 3 44
-
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 .
100 s
—
g

|Dnst020?ns |

2.7.1 Displaying Wavefor ms after Running a Simulation

If you display waveforms after running a simulation and want to see the waveforms from
the beginning of time, you will need to restart your design (using the restart command) and
rerun the ssimulation.

2.7.2 Zooming

When in the wave portion of the waveform window, pressing the right mouse button allows
the following zoom options: In 2x, Out 2x, Full, Last, and Range. In addition, zooming to
an area can be done by clicking the middle mouse button and then dragging in a horizontal
direction.

2.7.3 Radix

The radix of the selected signal (or signals) can be specified using one of the following
waveform menu commands.

Format > Radix > Hexadecimal
Format > Radix > Unsigned (positive decimal)
Format > Radix > Decimal (signed decimal)

Alternately you can access a similar menu with the right mouse button when selecting the
signal(s).
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2.7.4 Selecting Signals

Select one signal by clicking the left mouse button on its name.
To select multiple signals,
1. Select one signal and then press shift-left mouse button to select arange
2. Select one signal and then add more signals by pressing ctrl-left mouse button.

2.7.5 Moving Signals
Select signal(s) and drag to new location in wave window.

2.7.6 Using Cursors

The active cursor is shown in bold. To make a cursor the active cursor, click on it with the
left mouse button. To add cursors, use the "Add > Cursor" waveform menu command.
When more than one cursor is displayed, measurements can be made between adjacent
CUrsors.

To accurately place a cursor, use the find next change symbols (shown below) to move the
active cursor to the next change of the selected signal. Alternately dragging a cursor over
an edge of the selected signal will cause the cursor to try to snap to the edge.

Find next change to right
Find next change to left

[0-@@ S 4 2B O-ME% ||[x a4 n B|| dEeN e £ 5

| @i - 4 «a B TwudEERAT BPeB-RAWe | [QQQaR

2.7.7 [Optional] Saving and Restoring Waveforms
To save waveforms, use the following waveform window menu:

File > Save Format .

To Load (Restore) waveforms, use the following waveform window menu:

File > Load Format .
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Using ModelSim

2.7.8 [Optional] Selecting Individual Signalsto Display

Add the objects window to the modelsim GUI using the menu command, "View >
Objects’. The window will now look as shown below. To display an individual signal in a
given design, select the design in the sim window (such as u_inc shown), right click on a
signal in the objects window and specify the "Add to Wave > Selected Signals'. Note the
new waveform for Z in the docked wave window.
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3 Transtioning to the Next L ab

There is no need to quit the ssimulator to go to the next lab. Y ou can simply compile more
designsinto the library and then run another simulation.

Notethat if the next lab isin adifferent directory that you need to end the simulation with the
ModelSim menu command "Simulate > End Simulation”, before you can usethe
change directory menu command "File > Change Directory".
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4 [Optional] Setting Simulator Time Resolution

Simulator resolution is specified when loading a design for smulation. To set the simulator
resolution, select "Simulate > Start Simulation” from the Model Sim menu. The resulting pop-up
works just like the workspace library tab, except it also alows the simulation resolution to be
specified as shown below.

@ Start Simulation

Design I WHDL ] Yerilog ] Libraries ] SDF ] Others ] a3
I, T Path Fa' o . . .
LTI N W 1 simulation Resolution
+—ﬂ]l mt|UPF Library $MODEL_TECH/. . fupf_lib
4 mtom Ubrary  $MODEL_TECH]..furm-1,0-EA Note this is not the default run length.
1.—]]]1 werilog Library $MODEL_TECH]. . fverilog /
gl witalzano Library  $MODEL_TECH/.. fwitalz000 /
= work, Library wiork,
_I_:E inc Entity CifstudentfvhdlIntro/Chipperivhdl_src. .. Use th|S as directed in Iab 2 Optional
M _optl Optimized. ., StepS Only
™M _opt Optimized. .. -
Design Unit(s) Resolution
|wm:k .incth defaultc J
default
Qptimization
[V Enable optimization 0|:|t|r-]-Ufs
100fs
L les icel
100ps —
V&
10ns

5 Directory Structures & Running Scripts

Currently we are running the simulator out of the VHDL source directory (vhdl_src). If you
look in this directory, you will find that the simulator has added a few filesto it (modelsim.ini,
vsaim.wlf, and the directory work). An alternate way to organize a project isto have a separate
directory for source files and separate directories for the simulator and synthesistools. The
following directory structure is being used for these |abs:

Chipper

I ]
vhdl_src sim_mti fpga_xilinx

Exit out of thesimulator. Inthedirectory vhdl_src, delete any file that does not have a*.vhd
extension. Delete the subdirectory work.

Start the ssmulator. Use "File > Change Directory" to go to the directory

VhdlIntro/Chipper/ssim_mti. Execute the script (for Lab6 it is: TbL edFlasher_lab6.tcl) using
"Tools> TCL > Execute Macro ...".
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